研究報告拆解

Langflow 兩個關鍵漏洞:未認證 RCE 與 MCP 端點認證繞過

IBM 揭露 Langflow 1.0.0 至 1.12.8 版存在兩個 CVSS 9.8 關鍵漏洞,允許遠端未認證攻擊者繞過認證或執行任意程式碼。其中 CVE-2026-93680 為 MCP 工具列舉端點的認證繞過,CVE-2026-110186 為程式碼生成控制不當的 RCE。漏洞源自預設開啟的自動登入(LANGFLOW_AUTO_LOGIN)與不完整的修補。唯一修補版本為 1.13.0。

30 秒看懂
  • IBM 於 2026 年 10 月 28 日發布公告(29 日更新),揭露 Langflow 1.0.0 至 1.12.8 版存在四個漏洞,其中兩個為 CVSS 9.8 關鍵漏洞,允許遠端未認證攻擊者繞過認證(CVE-2026-93680)或執行任意程式碼(CVE-2026-110186)。CVE-2026-93680 為「透過 MCP 工具列舉的未認證遠端程式碼執行」,攻擊者可連線到 Langflow 的 MCP 端點而不需憑證,啟動 session 並列舉伺服器提供的工具。Metasploit Framework 已有公開模組利用 CVE-2026-93680,雖然該模組不執行程式碼,但展示了認證繞過的可行性。
  • 漏洞源自預設開啟的自動登入功能(LANGFLOW_AUTO_LOGIN),該設定在 1.12.8 版仍預設啟用,讓使用者以 superuser 身分自動登入而不需輸入密碼。程式碼註解警告「此設定繞過認證,應只在開發環境使用」。IBM 指出其中一個漏洞為「對自動登入安全控制的不完整修補」,但未說明關閉自動登入的伺服器是否仍受影響。公開的 Metasploit 模組在測試時,Langflow 1.8.4 的自動登入為開啟狀態。
  • 唯一修補版本為 1.13.0(2026 年 10 月 22 日發布),該版本預設關閉自動登入。同日發布的 1.12.8 仍有漏洞,PyPI 至 11 月 2 日未見更新的 1.12.x 版本。IBM 未提供無法立即更新的伺服器的臨時解決方法。漏洞目前不在 CISA KEV 清單(截至 10 月 30 日更新),但 CISA KEV 已列出其他六個 Langflow 漏洞,最近一次為 8 月新增的 CVE-2026-9198。IBM 於 10 月 29 日另外發布 29 個 Langflow 漏洞的 CVE 記錄,其中 CVE-2026-104339 同為未認證 RCE、CVSS 9.8,修補版本為 1.12.4 與 1.12.5。33 個 CVE 記錄均未列出 1.13.0 為受影響版本。

發生了什麼

來源:本文整理自 The Hacker News 於 2026 年 11 月 2 日發布的報導,引述 IBM 於 10 月 28 日發布(29 日更新)的安全公告。原文連結,原文發布日期為 Mon, 02 Nov 2026 17:20 +0530。

Langflow 是一個建立 AI agent 與工作流程的開源工具,它的漏洞回報由 IBM 處理。2026 年 10 月 28 日,IBM 發布安全公告,揭露 Langflow 從 1.0.0 至 1.12.8 的所有版本都存在多個漏洞,其中兩個為 CVSS 9.8 關鍵漏洞,允許遠端攻擊者不需要帳號就能繞過認證或執行任意程式碼。

唯一的修補版本是 1.13.0,於 2026 年 10 月 22 日發布。這些漏洞目前不在 CISA 的 Known Exploited Vulnerabilities (KEV) 清單上(截至 10 月 30 日更新),但 CISA KEV 已列出其他六個 Langflow 漏洞,最近一次是 8 月新增的 CVE-2026-9198。

四個漏洞的細節

IBM 公告列出四個漏洞(首次發布於 10 月 28 日,29 日更新):

CVECVSS 評分(IBM)需要帳號IBM 描述的影響
CVE-2026-936809.8(關鍵)否繞過安全限制,因認證不當
CVE-2026-1101869.8(關鍵)否執行任意程式碼,因程式碼生成控制不當
CVE-2026-1101938.8(高)是(低權限帳號)讓 Agentic Assistant 生成或提交會在伺服器上執行作業系統指令的元件程式碼
CVE-2026-1101926.5(中)是從防護不足的憑證中取得敏感資訊

其中一個漏洞是「透過 Model Context Protocol 工具列舉的未認證遠端程式碼執行」。透過 MCP,Langflow 可以將它的工作流程(flows)作為工具提供給支援 MCP 的 AI 應用程式。

公開的 Metasploit 模組

公開的 Metasploit Framework 已經有模組利用 CVE-2026-93680(認證繞過)。該模組連線到 Langflow 伺服器的 MCP 端點而不需憑證,啟動 session,並列舉伺服器提供的工具。它不執行程式碼或指令。

模組作者列出受影響版本為 Langflow 1.5.0 至 1.11.4,這個範圍比 IBM 列出的(1.0.0 至 1.12.8)窄。

該模組在 Langflow 1.8.4 上測試,自動登入為開啟狀態。

自動登入的問題

當自動登入開啟時,Langflow 讓使用者以 superuser 身分登入,而不提示他們輸入密碼。設定 LANGFLOW_AUTO_LOGIN 在 Langflow 1.12.8 預設為啟用。程式碼描述警告「它繞過認證,應只在開發環境使用」。

四個漏洞中的另一個是「對自動登入安全控制的不完整修補」。公告未說明關閉自動登入的伺服器是否仍會受影響。

如何更新至 1.13.0

Langflow 1.13.0 於 2026 年 10 月 22 日發布。同日發布的 1.12.8 版仍有這些漏洞,PyPI 至 11 月 2 日未見更新的 1.12.x 版本。IBM 沒有提供臨時解決方法給無法立即更新的伺服器。

Langflow 1.13 預設關閉自動登入。更新步驟:

  1. 備份資料庫、secret key 與上傳的檔案
  2. 如果伺服器使用自動登入,為現有帳號準備密碼登入(依照 Langflow 的更新指引)
  3. 更新 Python 套件:pip install --upgrade "langflow==1.13.0"。對於 Docker,改用 langflowai/langflow:1.13.0 image,並保留部署的持久資料
  4. 如果更新後無法登入,依照指引的復原步驟操作。不要刪除或重新安裝 Langflow 來恢復存取,Langflow 文件警告這會永久移除你的工作流程

IBM 另外發布 29 個漏洞的 CVE

10 月 29 日,IBM 另外發布 29 個 Langflow 漏洞的 CVE 記錄,修補版本為 1.12.4 與 1.12.5。其中 CVE-2026-104339 同樣可讓未認證攻擊者執行任意程式碼,IBM 評為 CVSS 9.8。

這 33 個 CVE 記錄(包含前述四個)均未列出 1.13.0 為受影響版本。

該怎麼做

立即更新至 1.13.0

更新是唯一的解決方法。使用以下指令:

# Python 套件
pip install --upgrade "langflow==1.13.0"

# Docker
# 改用 image langflowai/langflow:1.13.0
# 保留部署的持久資料

更新後檢查實際版本:

pip show langflow

如果使用自動登入

如果你的伺服器使用自動登入,更新到 1.13.0 後:

  1. 為現有帳號設定密碼
  2. 依照 Langflow 的更新指引操作
  3. 如果無法登入,依照復原步驟操作
  4. 不要刪除或重新安裝 Langflow

限制網路存取

因為攻擊需要網路存取 Langflow 的 MCP 端點或 API,限制來源 IP 可以降低風險:

  • 使用防火牆規則,只允許信任的 IP 或網段
  • 檢視日誌是否有非預期的 MCP 連線
  • 確認 MCP 端點是否真的需要對外開放

你可以學到什麼

站在攻擊者的角度:我不需要你的帳號密碼。我直接連到你的 Langflow MCP 端點,因為你開了自動登入,或是你的自動登入修補不完整,我就能繞過認證。我可以列舉你的伺服器提供哪些 AI 工具,也可以透過程式碼生成的漏洞執行任意程式碼。如果你用的是 1.12.8 或更早版本,你的伺服器就是我的。Metasploit 已經有現成的模組,任何人都能試。

lessons本案的 7 個教訓
  1. 01
    預設啟用的危險設定是嚴重的安全風險:LANGFLOW_AUTO_LOGIN 預設啟用,讓所有使用者以 superuser 身分登入,程式碼註解明確警告應只在開發環境使用,但 1.12.8 仍預設啟用。
  2. 02
    「開發環境專用」的功能不應該預設啟用:即使有警告,預設啟用的危險功能會讓不知情的使用者暴露在風險中。
  3. 03
    不完整的修補比沒有修補更危險:IBM 指出其中一個漏洞為「對自動登入安全控制的不完整修補」,這表示先前的修補嘗試未成功,而使用者可能以為問題已解決。
  4. 04
    公開的 exploit 降低攻擊門檻:Metasploit 模組的存在意味著任何人都能利用這個漏洞,不需要深入的技術知識。
  5. 05
    未認證的 RCE 是最嚴重的漏洞類型之一:CVSS 9.8 代表攻擊者不需要帳號就能執行任意程式碼,幾乎等同於完全控制伺服器。
  6. 06
    版本號的陷阱:同日發布的 1.12.8 與 1.13.0 中,只有 1.13.0 修補了漏洞,使用者可能因版本號接近而誤以為 1.12.8 也是安全的。
  7. 07
    刪除或重新安裝不是復原的好方法:Langflow 文件明確警告刪除或重新安裝會永久移除工作流程,這凸顯了備份的重要性。
keywords重點學習:最需要學習的 10 個關鍵字6 個
  1. 01
    CVE-2026-93680
    Langflow 認證繞過漏洞,CVSS 9.8,允許未認證攻擊者透過 MCP 端點繞過認證。
  2. 02
    CVE-2026-110186
    Langflow RCE 漏洞,CVSS 9.8,允許未認證攻擊者執行任意程式碼,因程式碼生成控制不當。
  3. 03
    LANGFLOW_AUTO_LOGIN
    Langflow 的自動登入設定,預設啟用,讓使用者以 superuser 身分登入而不需密碼,是漏洞的成因之一。
  4. 04
    MCP(Model Context Protocol)
    讓 Langflow 將工作流程作為工具提供給 AI 應用程式的協定,CVE-2026-93680 透過 MCP 端點繞過認證。
  5. 05
    Metasploit Framework
    公開的滲透測試框架,已有模組利用 CVE-2026-93680,降低攻擊門檻。
  6. 06
    Langflow 1.13.0
    唯一修補這些關鍵漏洞的版本,預設關閉自動登入。
try today今天就可以來試試約 15 分鐘

全部唯讀,不改任何設定;做完你會知道自己有沒有同樣的破口。

  1. 檢查 Langflow 版本
    pip show langflow
    看到什麼代表什麼:確認版本是否為 1.13.0。如果是 1.0.0 至 1.12.8,立即更新。
  2. 檢查 Docker image 版本
    docker image ls | grep langflow
    看到什麼代表什麼:確認 image 標籤是否為 1.13.0。
  3. 檢查自動登入設定
    echo $LANGFLOW_AUTO_LOGIN
    看到什麼代表什麼:如果回傳 true 或 1,自動登入為開啟狀態。1.13.0 預設關閉。
  4. 備份資料
    看到什麼代表什麼:備份資料庫、secret key 與上傳的檔案,然後更新至 1.13.0。
  5. 更新至 1.13.0
    pip install --upgrade "langflow==1.13.0"
    看到什麼代表什麼:更新完成後再次檢查版本,確認為 1.13.0。
  6. 為帳號設定密碼
    看到什麼代表什麼:如果先前使用自動登入,更新後必須為現有帳號設定密碼。
  7. 檢視伺服器日誌
    看到什麼代表什麼:查看是否有非預期的 MCP 連線或程式碼執行記錄。
  8. 限制網路存取
    看到什麼代表什麼:使用防火牆規則,只允許信任的 IP 存取 Langflow API 與 MCP 端點。

如果你使用 Langflow

  1. 立即更新至 1.13.0,這是唯一的修補版本
  2. 備份資料:資料庫、secret key、上傳檔案
  3. 關閉自動登入(1.13.0 預設關閉),為現有帳號設定密碼
  4. 限制網路存取:只允許信任的 IP 存取 API 與 MCP 端點
  5. 檢視日誌:確認沒有非預期的 MCP 連線或程式碼執行
  6. 不要刪除或重新安裝 Langflow 來恢復存取

兩個 CVSS 9.8 的未認證 RCE 與認證繞過漏洞,已有公開的 Metasploit 模組,今天就更新。

來源

分享
精選拆解直送信箱

每篇新文章一封:三點摘要、關鍵字定義、今天能做的一件事。

延伸閱讀

研究報告拆解

Ivanti Connect Secure 三漏洞鏈攻擊:繞過認證、執行程式碼、提升權限到 root

美國 CISA 將 Ivanti Connect Secure 的兩個漏洞(CVE-2026-111357、CVE-2026-118527)列入 KEV 清單,這兩個漏洞與先前的 CVE-2026-104935 組成完整攻擊鏈,讓攻擊者從未認證狀態提升到 root 權限。威脅組織 UTA0576 已在野外使用這組漏洞鏈竊取憑證與 Active Directory 資料,但未部署 web shell 或惡意軟體。Ivanti 已發布修補版本。

  • 2026/11/01
  • 每日拆解
研究報告拆解

LXD 與 MicroCloud CVSS 10.0 認證繞過:只要公鑰就能冒充信任客戶端

Canonical 的 LXD 與 MicroCloud 存在 CVSS 10.0 關鍵漏洞 CVE-2026-112816,允許攻擊者只憑信任客戶端的公開憑證(不需私鑰)就能冒充該客戶端登入 HTTPS API。漏洞成因是伺服器檢查 TLS 憑證鏈時,比對了所有憑證而非僅檢查葉憑證,而 TLS 連線只能證明客戶端擁有葉憑證的私鑰。漏洞由 Incus 專案回報,Canonical 已發布修補版本。

  • 2026/11/02
  • 每日拆解
事件拆解

WordPress 核心 RCE 漏洞引來 24 小時內 6.3 萬次攻擊:升級窗口的競賽條件讓攻擊者有機可乘

WordPress Core 4.7 至 7.1.3 版本存在一個 CVSS 8.1 的遠端程式碼執行漏洞,攻擊者可在 WordPress 執行完整套件升級時,透過可預測的暫存目錄路徑觸發安裝程式並執行程式碼。Wordfence 在修補版本發布後 24 小時內攔截 62,969 次攻擊嘗試,攻擊者持續輪詢 setup-config.php 等路徑試圖抓住短暫的升級窗口。

  • 2026/10/30
  • 每日拆解